SOS-FORUM

Derniers sujets

» Silence Inside Me - Ouverture
par Solitude 3/3/2018, 12:36

» ATLANTIC CITY - rpg city
par Solitude 15/3/2017, 10:41

» Bonne Année 2015
par Chantra Chantrapa 5/3/2017, 20:31

» Rio de Janeiro
par Solitude 14/9/2015, 15:34

» Bon Anniversaire Zeco
par Laurent 29/5/2015, 06:29


Vous n'êtes pas connecté. Connectez-vous ou enregistrez-vous

Voir le sujet précédent Voir le sujet suivant Aller en bas  Message [Page 1 sur 1]

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
En allant faire un tour dans une section ouverte de notre forum, ze_chaofan a constaté :
ze_chaofan a écrit:En fait, pour ton image de fond au champs à coins arrondis sur l'index ainsi que les messages, ceux qui ne sont pas prêts à l'origine pour des images, il faut mettre le coin arrondi sur l'image de fond.

Comment modifier cela ?


PS : pas de rush hein !



Dernière édition par final-blond le 9/3/2009, 19:49, édité 1 fois

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Petite explication :

Imagine que l'on superpose 4 tableaux html (ça tu connais, je l'ai fait avec des div, mais ça revient au même) de mêmes dimensions. Dans chacun de ces tableaux, on met comme image de fond 1 coin arrondis, situé chacun dans un coin différent de chaque tableau.
On a utilisé cette méthode car il n'est pas possible de mettre quatre images de fond dans une zone.
Donc reprenons, on a nos quatre tableaux superposés, qui forment visuellement un ensemble de taille variable qui possède des coins arrondis.
Comme chaque tableau superposé est transparent, l'ensemble final sera transparent. Donc pour mettre une couleur de fond à la zone, on met une couleur de fond au tableau du dessous, celui qui gère un des coins (ici le coin haut/gauche).
Mais, il possède déjà une image de fond, le coin arrondi haut/gauche, et qui jamais tu mets une image à la place de la couleur, l'image prendra la place du coin.

Donc, si tu veux mettre une image de fond, il te faudra faire une grande image (suffisante pour couvrir toute la zone), et mettre dans cette image le coin arrondi gauche que l'on retrouve habituellement, en haut à gauche.


Cependant, sache que sur la version 1.0.1, j'ai réglé le soucis pour la plupart des champs à coins arrondis.

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
ze_chaofan a écrit:Donc, si tu veux mettre une image de fond, il te faudra faire une grande image (suffisante pour couvrir toute la zone), et mettre dans cette image le coin arrondi gauche que l'on retrouve habituellement, en haut à gauche.

Cependant, sache que sur la version 1.0.1, j'ai réglé le soucis pour la plupart des champs à coins arrondis.
Très bien, alors on attend la version 1.0.1 parce que là, si j'ai bien tout compris, ça demanderait quand même une grosse modif des images de fond...

Ou bien je garde la couleur en attendant... We'll see.

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Grosse modification, non, c'est même assez simple.
Mais pour un fond en mosaïque comme sur ton forum, il faudrait faire une image de taille considérable, ce qui ne ferait que ralentir le forum.

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
ze_chaofan a écrit:pour un fond en mosaïque comme sur ton forum, il faudrait faire une image de taille considérable, ce qui ne ferait que ralentir le forum.
Oui c'est bien ce que je pensais.

Alors je vis remettre les couleurs en attendant, pas grave.

Bon me reste plus qu'à retrouver les champs et partir du css par défaut du SF-BB...

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Il me semble que c'est ceux ci :
/*Couleur_Arrondis_Interieur-------------------------------------------------*/
.upperleft2{ background-color: #color; }
/*Couleur_Fond_Cellules-------------------------------------------------*/
td.row1,td.row2,td.row3,profileopen,.upperleft3 { background-color: #color; }

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
Oui il me semble... Tu peux voir et me dire si là tout est comme devrait être la version, steuplé Môssieur ?

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Yep, ça m'en a tout l'air, bien que la couleur de ceci :
/*Couleur_Arrondis_Interieur-------------------------------------------------*/
.upperleft2{ background-color: #color; }
Ne soit pas visible.

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
ze_chaofan a écrit:Yep, ça m'en a tout l'air, bien que la couleur de ceci :
/*Couleur_Arrondis_Interieur-------------------------------------------------*/
.upperleft2{ background-color: #color; }
Ne soit pas visible.
Ah, ça y est pourtant... Ne serait-ce parce qu'on a interverti duex blocs sur l'autre topic :

ze_chaofan a écrit:Re...
Alors voilà le problème : Les champs arrondis du forums autres que ceux prévus pour avoir une image de fond ne sont pas faits pour en avoir une. En fait, leur image de fond sont les coins.
Anyway, on peut comment essayer ceci :

Cherche cette partie :
/*Couleur_Fond_Cellules-------------------------------------------------*/
td.row1,td.row2,td.row3,profileopen,.upperleft3
{ background-image:
url('http://static1.grsites.com/archive/textures/orang/orang029.gif'); }

Et déplace la en dessous de celle :

/*Image_Coins_Arrondis-------------------------------------------------*/
.upperleft,.upperleft2,.upperleft3 {background-image: url("https://i.servimg.com/u/f61/13/61/91/69/corner10.gif");}
.upperright,.upperright2,.upperright3 {background-image: url("https://i.servimg.com/u/f61/13/61/91/69/corner11.gif");}
.lowerleft,.lowerleft2,.lowerleft3 {background-image: url("https://i.servimg.com/u/f61/13/61/91/69/corner13.gif");}
.lowerright,.lowerright2,.lowerright3 {background-image: url("https://i.servimg.com/u/f61/13/61/91/69/corner12.gif");}

Dis moi si ça s'améliore.

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Final-Blond a écrit:Ah, ça y est pourtant... Ne serait-ce parce qu'on a interverti duex blocs sur l'autre topic
Ah, oui, très probable en effet !
Bonne remarque !

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
Anh han... si je remets comme avant ça remettra les lignes blanches non ?

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Si tu as mis une couleur, non.
La ligne n'est pas blanche en réalité, mais c'est plutôt un espace entre les deux.

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
ze_chaofan a écrit:Si tu as mis une couleur, non.
La ligne n'est pas blanche en réalité, mais c'est plutôt un espace entre les deux.

Ok j'ai remis le bloc comme avant... Tu vois maintenant ? (j'avoue que je ne vois pas ce que tu ne vois pas et que devrais voir... va savoir^^)

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Yep, c'est OK !

Final-Blonde
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
Ok, c'est résolu pour moi.



Merci ze_chaofan.

Zeco
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
So, j'envoie aux archives.


Contenu sponsorisé

Voir le sujet précédent Voir le sujet suivant Revenir en haut  Message [Page 1 sur 1]

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum

 
  •  

Créer un forum | © PunBB | Forum gratuit d'entraide | Signaler un abus | Forum gratuit