SOS-FORUM

Derniers sujets

» Silence Inside Me - Ouverture
par Solitude 3/3/2018, 12:36

» ATLANTIC CITY - rpg city
par Solitude 15/3/2017, 10:41

» Bonne Année 2015
par Chantra Chantrapa 5/3/2017, 20:31

» Rio de Janeiro
par Solitude 14/9/2015, 15:34

» Bon Anniversaire Zeco
par Laurent 29/5/2015, 06:29


Vous n'êtes pas connecté. Connectez-vous ou enregistrez-vous

Voir le sujet précédent Voir le sujet suivant Aller en bas  Message [Page 1 sur 1]

1 comment monter mon header flash ? le 26/4/2010, 04:04

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
Bonsoir je voudrais monté mon header flash ( www.Team-SoF.cpm ) de quelque pixel !

Merci !


quierra
(Membre)
Voir le profil de l'utilisateur http://www.themes-fa.com
Coucou, je ne sais pas vraiment ou tu l'as placé ton code ! en général
je dis de mettre un margin-top de -(le nombre de pixel) à .site-desc,
mais cette class n'apparait pas chez toi, ou peut être pas sur phpbb2 !

Le mieux pour le bouger est de le mettre dans un div.

Tu vas dans le template "overall_header_new"

Affichage --> Templates --> Général --> overall_header_new

Tu repères ces lignes :


Code:

cellspacing="0" cellpadding="10" border="0" align="center">
       
            [table class="bodylinewidth" width=""][tr][td class="bodyline"]
               
border="0">
                   


Et tu rajoutes une class ou ID ou tu placeras le code de ton flash :

Code:
<table cellpadding="0" cellspacing="0" width="100%"><tr></tr></table>
cellspacing="0" cellpadding="10" border="0" align="center">
id="remonter_flash" style="margin-top: -20px;"> le code de
ton flash
 

       

            <table class="bodylinewidth" width=""><tr><td class="bodyline">

               
border="0">

                   


Donc voila, on n'a créer un ID : #placer_flash dans lequel se trouve
maintenant ton header.

Si tu préfères le remonter par le css, tu ôtes le "margin-top" et :

Affichage --> Couleurs --> Onglet feuille de style css

et tu colles :

#remonter_flash{
margin-top: -20px;
}

le margin-top de -20 à régler selon tes besoins.

Au fait, pourquoi avoir enregistré ton flash sur un calque aussi grand ?
tu as une marge énorme en bas qui ne sert à rien et qui alourdie
inutilement ton flash.

Chouette design....
[/td][/tr][/table]

avatar
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
Hello Quierra, il y a comme des erreurs dans le code (avec du BBcode), ainsi que le code de la fin...
WYSIWYG activé ?

Est-ce de ce bloc à repérer dont tu parles (c'est le seul avec un padding="10") :
Code:
<table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
      <tr>
         <td class="bodyline">
            <table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>


quierra
(Membre)
Voir le profil de l'utilisateur http://www.themes-fa.com
Ha merdeee ! mais comment il faut faire alors pour poster du code ? pourtant c'était bon à la prévisualisation !

Ben tient, ça vient peut être du fait que j'ai prévisualisé, chose que je ne fais pas habituellement ! car justement y a le risque que le code se face là malle !

bon je le reposte et si là y a un souci, faudrait m'expliquer comment poster des codes sur ce forum.

Tu vas dans le template "overall_header_new"

Affichage -->
Templates --> Général --> overall_header_new

Tu repères ces
lignes :

Code:

<table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
        <tr>
            <td class="bodyline">
                <table width="100%" cellspacing="0" cellpadding="0" border="0">
                    <tr>


Et tu rajoutes une class ou ID ou tu placeras le
code de ton flash :

Code:

<table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}"
cellspacing="0" cellpadding="10" border="0" align="center"><div id="remonter_flash" style="margin-top: -20px;"> le code de
ton
flash </div>
        <tr>
            <td class="bodyline">
                <table width="100%" cellspacing="0" cellpadding="0"
border="0">
                    <tr>

Donc voila, on n'a créer un ID : placer_flash
dans lequel se trouve
maintenant ton header.

Si tu préfères
le remonter par le css, tu ôtes le style=margin-top et :

Affichage
--> Couleurs --> Onglet feuille de style css

et tu colles :

#remonter_flash{
margin-top: -20px;
}

Bon j'envoie, en verra ce que ça donne...


quierra
(Membre)
Voir le profil de l'utilisateur http://www.themes-fa.com
Ça m'a l'air bon... pardon pour le flood mais je ne vais pas risquer d'éditer

Edit ! je viens de voir une erreur dans mon commentaire...

Quand je dis "on n'a crée un ID "placer_flash", je voulais dire "remonter_flash"... enfin tu l'as sans doute compris.

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
Donc merci pour votre aide pour commencer ( et mon compliment sur mon Design =) ) donc ça marche a peu près =) mais il y plusieurs bug =( premièrement la largeur du forum n'est pas la même entre Firefox et IE ensuite la ça bug pas mal; illustration :



pour infi Mozilla et en haut Wink et voici un extrait du code que j'ai mis :



Code:
   <a name="top"></a>
   {JAVAscript}
   <table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}" cellspacing="0" cellpadding="10" border="0" align="center">
      <tr>
         <td class="bodyline">
            <table width="100%" cellspacing="0" cellpadding="0" border="0">
               <tr>

<table class="bodylinewidth" width="{T_BODY_TABLE_WIDTH}"
cellspacing="0" cellpadding="10" border="0" align="center"><div id="remonter_flash" style="margin-top: -35px;"> <style type=text/css> body { background-position: top center;}</style> <embed src=http://photomaniak.com/upload/out.php/i915423_1.swf width=995 height=320 type=application/x-shockwave-flash wmode=transparent quality=high allowscriptAccess=always> </div>
        <tr>
            <td class="bodyline">
                <table width="100%" cellspacing="0" cellpadding="0"
border="0">
                    <tr>
                  <!-- BEGIN switch_logo_left -->
                  <td><a href="{U_INDEX}"><img src="{LOGO}" id="i_logo" border="0" alt="{L_INDEX}" vspace="1" /></a></td>

merci d'avance !

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
up ^^

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
personne pour m'aider ???

avatar
Final-Blonde
Staff du forum
Voir le profil de l'utilisateur http://sansfil.forumactif.com/
Euh Tivrius, je préfère que Quierra continue sur ce tuto.
Sois patient car elle est très occupée, mais je suis sûre que dès qu'elle le pourra elle viendra voir ça avec toi.

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
okok merci le prend mon mal en patiente !

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
toujours occupé ?

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Hello...

Je n'ai vraiment pas l'habitude des logos en flash, mais peut être que cela vient du fait que le logo est dans le cadre du forum :

Code:
<div id="remonter_flash" style="margin-top: -35px;"> <style type=text/css> body { background-position: top center;}</style>  <embed src=http://photomaniak.com/upload/out.php/i915423_1.swf width=995 height=320 type=application/x-shockwave-flash wmode=transparent quality=high allowscriptAccess=always> </div>
Il faudrait déplacer ça en dehors du tableau du forum, et mettre un text-align: center; pour centrer la balise embed, ça pourrait marcher, non ?

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
ok je vais voir je désespère ...

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
nan dsl ça ne marche pas je n'arrive pas le monter correctement

avatar
Invité
Invité
Dans ton css, essaie cela

Code:
table.bodylinewidth {
position: relative;
top: -20px;
}

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
bravo c'est vraiment parfait maintenant Vide je vous remercie encore une fois Vide

avatar
Invité
Invité
Content pour toi

avatar
Invité
Invité
Tu peux faire pareil en bas en mettant bottom au lieu de top, mais vérifie sur les autres navigateurs aussi.

avatar
Tivrius
(Membre)
Voir le profil de l'utilisateur
j'ai vérifié ca va ça passe... encore merci pour tout Vide!


Contenu sponsorisé

Voir le sujet précédent Voir le sujet suivant Revenir en haut  Message [Page 1 sur 1]

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum

 
  •  

Créer un forum | © PunBB | Forum gratuit d'entraide | Signaler un abus | Forum gratuit