installer un sélecteur de thèmes
SOS-FORUM.com
     

Derniers sujets

» ATLANTIC CITY - rpg city
par Solitude 15/3/2017, 10:41

» Bonne Année 2015
par Chantra Chantrapa 5/3/2017, 20:31

» Rio de Janeiro
par Solitude 14/9/2015, 15:34

» Bon Anniversaire Zeco
par Laurent 29/5/2015, 06:29

» Plateforme d'affiliation Afflight
par Landry85 5/5/2015, 10:04


Vous n'êtes pas connecté. Connectez-vous ou enregistrez-vous

Aller à la page : 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas  Message [Page 1 sur 2]

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Bonsoir,
Je voudrais installer le sélecteur de thèmes (j'ai trouvé un tuto de ze_chaofan sur ce forum).
J'ai essayé cet après-midi mais en vain.
En fait, je voudrais savoir comment je dois remplir le script avec les différents thèmes voulus et je voudrais bien sûr conserver le thème actuel en thème principal.

En résumé, j'ai mis dans le panneau d'admin, dans description du forum le script :
Code:
 <style type=text/css>body {margin-top: 0px!important; padding-top: 0px!important;} #hitskin_preview {display: none!important; height:0px!important; } * html #hitskin_preview { display:none!important; height:0px!important;}</style>

Par contre c'est après que ça se gâte...

Il me reste ce script à placer :
Code:
 <select name="Themes" onchange="window.location.href=this.value" size="0" style="background-color: #ffffff; color: #000000; font-size: 10pt; font-family: arial; font-weight: normal;"><option selected>Choisissez un thème</option>
--- LES OPTIONS POSSIBLES ---
<option value="adresse_de_votre_forum">Thème de base</option></select>

J'ai essayé de mettre ça dans affichage, page d'accueil, généralités, contenu du message mais ça apparait sur ma page d'accueil du forum...

De plus, je ne sais pas trop comment remplir correctement les scripts.

j'ai repéré plusieurs thèmes :

http://demo.nicetheme.com/index.htm?theme_id=149558

http://demo.nicetheme.com/1-forum-f1/?theme_id=121268

http://demo.nicetheme.com/index.htm?theme_id=100001

http://demo.nicetheme.com/index.htm?theme_id=110695

http://demo.nicetheme.com/index.htm?theme_id=108453

et je voudrais donc garder mon thème actuel.

Je vous remercie beaucoup d'avance pour l'aide que vous pourrez m'apporter.



Dernière édition par luna47 le 10/2/2010, 23:12, édité 1 fois

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Apparemment les scripts disparaissent lorsque je valide le message !

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
Bonsoir Luna

Pour "conserver" les scripts il faut les placer entre les balises [code] Wink

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Merci !
Je vous l'ai dit, je suis un peu novice en la matière... Embarassed

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Hello...

Concernant les adresses à mettre, il n'est nécessaire d'en mettre que sur le premier (celui du thème par défaut.
Par exemple, pour ton code, il faut donc :


<select name="Themes" onchange="window.location.href=this.value" size="0" style="background-color: #ffffff; color: #000000; font-size: 10pt; font-family: arial; font-weight: normal;"><option selected>Choisissez un thème</option>
<option value="?theme_id=149558">Ambient Style</option>
<option value="?theme_id=121268">The Jelley</option>
<option value="?theme_id=100001">Magenta</option>
<option value="?theme_id=110695">Pistache</option>
<option value="?theme_id=108453">City Game</option>
<option value="adresse_ici">Thème de base</option></select>

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Je dois donc recopier ce script tel quel en ajoutant l'adresse de mon forum à la place du adresse_ici en rouge ?
Une question bête... où dois je copier coller ce script ?
Merci

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Alors oui, effectivement, il faut que mettes l'adresse de ton forum à la place du mot en rouge.

Aussi, vu que tu en phpbb3, tu peux le mettre dans le message d'accueil par exemple, ou dans un widget (quoique, je ne suis pas sûr que tous les thèmes gèrent les widgets parmis ceux là, donc les mettre dans le message d'accueil est une bonne idée).

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
mais pourquoi ce script est il visible ? je ne vois pas la petite fenêtre "choisissez votre thème" mais je vois le script sur ma page d'accueil...

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
As tu désactivé le mode automatique de l'éditeur ?
Retire tout, clique sur le bouton A/A, et recolle le code.

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Ah ça marche ! C'était ça ! merci mille fois !

Par contre, ça sert à quoi exactement ce bouton A/A car nous avons des problèmes pour écrire car le cadre d'écriture se met parfois en bleu clair et comme l'écriture du forum est bleu clair aussi, nous avons trouvé comme solution d'appuyer sur ce fameux bouton A/A pour que le cadre d'écriture redevienne bleu foncé. Ce n'est que du bricolage mais ça nous permet de pouvoir écrire, sinon on ne voit rien du tout à ce qu'on écrit...

Merci vous êtes génial !

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
C'est super, je viens d'essayer tous les thèmes ça marche nickel.
Par contre, j'ai encore une question à soumettre : sur certains thème il y a des images (par exemple écrit chocolat pistache) peut on supprimer cela ? ou encore le titre de mon forum disparait dans certains thèmes alors qu'il figure bien sur le thème de base. Y a t'il des choses à faire pour corriger cela ?
Encore un grand merci.

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Ok, super que ça soit bon.

luna47 a écrit:Par contre, ça sert à quoi exactement ce bouton A/A car nous avons des problèmes pour écrire car le cadre d'écriture se met parfois en bleu clair et comme l'écriture du forum est bleu clair aussi, nous avons trouvé comme solution d'appuyer sur ce fameux bouton A/A pour que le cadre d'écriture redevienne bleu foncé. Ce n'est que du bricolage mais ça nous permet de pouvoir écrire, sinon on ne voit rien du tout à ce qu'on écrit...
Quand il est activé, le mode appelé WYSIWYG, permet de voir ce que l'on va taper. Par exemple, lorsque l'on met du texte en gras, il est écrit en gras dans l'éditeur.
A l'inverse, lorsqu'il est désactivé, on voit les balises qui mettent en forme le texte.


luna47 a écrit:C'est super, je viens d'essayer tous les thèmes ça marche nickel.
Par contre, j'ai encore une question à soumettre : sur certains thème il y a des images (par exemple écrit chocolat pistache) peut on supprimer cela ? ou encore le titre de mon forum disparait dans certains thèmes alors qu'il figure bien sur le thème de base. Y a t'il des choses à faire pour corriger cela ?
Non, il n'est cependant pas possible de changer les thèmes d'hitskin.

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Et est il possible de trouver des thèmes ailleurs que sur Hitskin ?
Merci beaucoup de votre aide sinon je crois que j'y aurais passé un bon moment...

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Malheureusement, il n'y pas d'équivalent...
Il y a bien des forums spécialisés qui proposent leur thèmes, mais dans ce cas là, il faudrait un sélecteur bien plus évolué et compliqué.

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
luna47 a écrit:. Y a t'il des choses à faire pour corriger cela ?
Encore un grand merci.
Vala Wink

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Merci Tyli d'avoir supprimé l'écriture, cependant que dois je faire pour remplacer l'image sur le thème ?
Merci

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
PA/Affichage/Gestion des images/Mode avancé /Logo du forum : tu enlèves l'actuel et tu places cette

adresse à la place : http://i65.servimg.com/u/f65/13/65/20/92/i_logo11.jpg Wink

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Mais en fait, dans PA/Affichage/Gestion des images/Mode avancé /Logo du forum ce n'est pas cette image que j'ai, c'est le logo de mon forum que j'avais fabriqué comme je pouvais... Dans l'absolu, j'aurais bien aimé que mon logo apparaisse sur tous les thèmes mais ce n'est pas le cas...
Merci de votre aide, c'est très gentil.

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
C'est quoi ton logo ?

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
C'est en fait le nom de mon forum.

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
Il est possible de le mettre sur l'image Wink

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Nous constatons un petit problème sur le forum.
Si je choisis un thème autre que le thème de base du forum, à chaque fois que je valide un message, c'est le thème inititial qui réapparait après validation...
Y a t'il quelque chose à faire pour résoudre cela ? Je suis désolée de toutes ces questions.
Merci de vos avis et conseils.

avatar
Tyli
(Membre)
Voir le profil de l'utilisateur http://femmescompagnesdemil.forumactif.org/forum.htm
Alors là je ne sais pas !!Embarassed

si quelqu'un trouve la solution je veux bien te mettre ton logo sur l'image Wink , tu peux déjà me l'envoyer , je te ferai ça demain , après je pars en vacances cheers

avatar
luna47
(Membre)
Voir le profil de l'utilisateur
Merci beaucoup Tyli de ta proposition, (je me suis mise au tutoiement) pour l'instant j'essaie de régler mon problème de thèmes qui ne tiennent pas après validation des messages. Si je parviens à résoudre ce problème, je me pencherai sur le problème des images et du logo de mon forum. Tu peux partir en vacances tranquille je pense Smile
Si je n'arrive pas à résoudre ce problème, je pense que je serai obligée d'enlever le sélecteur de thèmes...
Ze_Chaofan, si tu passes par là, j'ai encore besoin de tes lumières !
Les membres rencontrent le même problème :
Ils choisissent leur thème préféré, tant qu'ils consultent et lisent le forum, pas de problème mais dès qu'ils valident un message, le thème de base réapparait...

avatar
Zeco
Administrateur absent
Voir le profil de l'utilisateur http://digs.forumactif.com/forum
Arg oui...

Ah, c'est pas normal ça... pourtant, auparavant, tout gardait bien...
Tss... FA a dut encore modifier des réglages...

Je t'avoue que je ne sais pas comment régler ça, je vais chercher voir si il y a moyen avec des cookies.


Contenu sponsorisé

Voir le sujet précédent Voir le sujet suivant Revenir en haut  Message [Page 1 sur 2]

Aller à la page : 1, 2  Suivant

Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum

 
  •  

Créer un forum | © PunBB | Forum gratuit d'entraide | Signaler un abus | Forum gratuit